windows 2008 R2 下 IIS7.5+PHP+Mysql+Zend完美运行fastcgi

windows-server-2008-R2

windows 2008 R2 下面IIS7.5已经对fastcg的支持有了很大改进,我们不建议朋友们再使用PHP-ISAPi模式。

本次环境搭建所有版本均经过多次测试保证无误!鉴于目前php5.3.1还不能完美的支持主流php系统,不建议大家使用!

windows2008 R2下面环境搭建分三种情况 大家可以根据自己的运行需要选择!

1 IIS7.5+PHP+Mysql+Wincache 1.0RC

这个环境组合大家已经看出来了 没有zend,

各个版本分别是:

PHP5.2.11–请注意是非线程安全版本 PHP 5.2.11 Non-thread-safe zip package

MYSQL5.0 x64,

Wincache1.0rc for5.2,这个大家可以去微软IIS官方下载,他将极大地提高您的系统运行效率!

如果您的服务器运行的都是开源程序,不需要zend,强烈建议您使用这个配置!

2 IIS7.5+PHP+Mysql+Zend+Xcache

此组合版本分别是

PHP5.2.11 请注意是线程安全版本PHP 5.2.11 zip package

MYSQL5.0 x64,

ZendOptimizer3.3.3-windows x86

Xcache1.3 for XCache-1.3.0-php-5.2.10-Win32-VC6-x86.zip

此组合可以完美运行当今主流的PHP系统,但是美中不足的是使用PHP线程安全版本无法加载wincache,很遗憾的一点!但是可以用xcache作为补充,但是相比PHP-ISAPI模式已经好多了!

3 鉴于IIS7.5的新特性,我们可以根据每个站点的具体情况定制属于他的专有运行环境!

在iis7.5 fastcgi模式下,IIS官方建议为每个站点设立单独的应用池,并且每个站点都可以拥有它自己的PHP.ini以及fastcgi.exe.允许在一台主机上运行不同版本的PHP.

本人专业承接windows server 2008 R2 系统安全策略配置,web环境部署,性能优化,web性能优化部署,windows 2008 R2 IIs7.5下ASP+asp.net+php-fastcgi完美运行安全环境部署,iis7.5下多版本php-fastcgi环境部署,IIS7.5、Mssql2008-sp2/mssql2008R2、Mysql5.0/mysql5.1安全部署,需要的朋友请联系我,QQ: 5343726 真诚与您合作!

目前共 0 条评论